CloudBees Security Advisory 2021-04-20

This advisory announces vulnerabilities in Jenkins, Cloudbees, CloudBees Jenkins Distribution and CloudBees Jenkins Platform

Denial of service vulnerability in bundled Jetty 

JENKINS-65280 / CVE-2021-28165

Jenkins bundles Winstone-Jetty, a wrapper around Jetty, to act as HTTP and servlet server when started using java -jar jenkins.war. This is how Jenkins is run when using any of the installers or packages, but not when run using servlet containers such as Tomcat.

Jenkins 2.285 and earlier, LTS 2.277.2 and earlier bundles Jetty 9.4.38 or earlier with multiple security vulnerabilities, including CVE-2021-28165. This vulnerability may allow unauthenticated attackers to cause a denial of service if Winstone-Jetty is configured to handle SSL/TLS connections.

Cloudbees 2.277.3.1 and also 2.249.31.0.1 updates the bundled Jetty to 9.4.39. Jetty was already previously updated to 9.4.39 in the 2.286 weekly release.

Severity

  • SECURITY-65280: High

Fix

  • CloudBees Traditional Platforms should be upgraded to version 2.277.3.1

  • CloudBees Cloud Platforms should be upgraded to version 2.277.3.1

  • CloudBees Jenkins Enterprise should be upgraded the Managed Masters and Operations Center to version 2.277.3.1

  • CloudBees Jenkins Platform (rolling train, CJP Operations Center and CJP Client Master (2.x.y.z) should be upgraded to version 2.277.3.1

  • CloudBees Jenkins Platform (fixed train, CJP Operations Center and CJP Client Master (2.249.x.0.z) should be upgraded to version 2.249.31.0.1

  • CloudBees Jenkins Distribution should be upgraded to version 2.277.3.1