CloudBees Security Advisory 2020-08-17

This advisory announces vulnerabilities in Jenkins, Cloudbees, CloudBees Jenkins Platform and CloudBees Jenkins Distribution

Buffer corruption in bundled Jetty 


SECURITY-1983 / CVE-2019-17638

Jenkins bundles Winstone-Jetty, a wrapper around Jetty, to act as HTTP and servlet server when started using java -jar jenkins.war. This is how Jenkins is run when using any of the installers or packages, but not when run using servlet containers such as Tomcat.

Jenkins 2.224 through 2.242 and LTS 2.222.1 through 2.235.4 bundles Jetty 9.4.27 with the security vulnerability CVE-2019-17638. This vulnerability may allow unauthenticated attackers to obtain HTTP response headers that may include sensitive data intended for another user.

Severity

Fix

  • CloudBees Traditional Platforms should be upgraded 2.235.5.1

  • CloudBees Cloud Platforms should be upgraded 2.235.5.1

  • CloudBees Jenkins Enterprise should be upgraded the Managed Masters and Operations Center to 2.235.5.1

  • CloudBees Jenkins Platform (rolling train, CJP Operations Center and CJP Client Master (2.x.y.z) should be upgraded to version 2.235.5.1

  • CloudBees Jenkins Platform (fixed train, CJP Operations Center and CJP Client Master (2.222.x.0.z) should be upgraded to version 2.222.42.0.1